Server Setup

Before installation of Tripal a web server must be configured and ready, and Tripal requires the following dependencies:

  1. A UNIX-based server (e.g. Ubuntu Linux or CentOS are the most popularly used).
  2. Web server software. The Apache web server is most commonly used.
  3. PHP version 5.6 or higher (the most recent version is recommended)
  4. PostgreSQL 9.3 or higher
  5. Drush 7 or higher
  6. Drupal 7.x

Additionally, knowledge of the Chado database schema is extremely helpful.

Instructions are provided here for setup of either an Ubuntu version 16.04 or CentOS (version 7) system.