Tripal Prerequisites

Tripal v3.x requires several Drupal modules. These include  EntityViews, CTools, Display Suite, Field Group, Field Group Table, Field Formatter Class and Field Formatter Settings modules.   Modules can be installed using the graphical Drupal website by clicking on the Modules link in the top adminstrative menu bar.  Instructions for instaling Modules via the web-interface can be found here:  https://www.drupal.org/documentation/install/modules-themes/modules-7. However, Drush can be quicker for module installation. The following instructions will show how to install a module using the Drush command-line tool. 

First, install the Entity module.  We will download the current version using the drush command. On the command-line, execute the following:

cd /var/www/html/sites/all/modules
drush pm-download entity

Typically for all module installation we should check the README for additional installation instructions. Next, enable the module using a drush command:

drush pm-enable entity

For basic Tripal functionality you must also enable the Views and CTools modules. You can specify as many module as desired on one line:

drush pm-download views ctools 
drush pm-enable views views_ui ctools 

Finally, Tripal works best when it can provide default display layouts.   To support default layouts you must also enable the remainig dependencies:

drush pm-download ds field_group field_group_table field_formatter_class field_formatter_settings
drush pm-enable ds field_group field_group_table field_formatter_class field_formatter_settings